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Lab Objectives 
Obtain information relevent to an ECO
Update the schematics
Update the PCB layout
Update the firmware
Send all the updates out

Skill Level 
Advanced – Attendees should have some general 
experience with EDA software and embedded 
development.

Time to Complete Lab 
50 Minutes

Lab Materials 
Please verify you have the following materials at 
your lab station.
Laptop booted to Fedora Electronics Lab
USB A to mini-B cable
R8C/33c Lab Board (“gR8C”)



LAB PROCEDURE

1 Gathering Information
Overview:
To begin our “day” we will check our email, read an ECO (Engineering Change Order), and surf the web 
to gather the information we'll need to implement the ECO.

Procedural Steps

Step 1.1 Make sure your gR8C board is not connected to your laptop.  You will be instructed to 
connect it later in the lab.

Step 1.2 Check your Email.  Click on the Evolution icon  in the taskbar.

Step 1.3 The default Inbox should be selected, and one new message from DevCon Marketing should 
be present.  Click on it to view it.

Step 1.4 The email includes an attached document.  Pull down the attachment's menu and select 
OpenOffice to view it with.

Step 1.5 After reading the ECO, use the X button in the window's upper right to close it.

 Question
1. Do you remember to where the LEDs were to be connected?
2. Do you have an R8C/33c Hardware Manual available?

Step 1.6 Surf the web to find an R8C/33C hardware manual.  Click on the Firefox icon  to start your 
web browser. 

 Your laptop is not actually connected to the Internet.  There are servers 
running on it to provide mail, web, and DNS for this lab. 
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LAB PROCEDURE
Step 1.7 Click on the R8C/33C Hardware Manual link.  This will download the file and start the PDF 

viewer.  Find section 1.4, the pin assignments.  Note where Port 1's pins are.

Step 1.8 Now that you have all the information you need to make the change, you may close the PDF 
and Email windows.

The first objective is now complete!

Rotate your die to 1 to show your progress.
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2 Updating Schematics
Overview:
The first step in our change is to update the schematics.  This part of the lab will teach you how to use 
gschem to change an existing schematic.

Procedural Steps

Step 2.1 Open the gR8C project files by double clicking on the “gR8C Project Files” folder on your 
desktop.

Step 2.2 Double click on the “hw” folder to get to the hardware design files.

 If you are unable to complete this section of the lab, you may copy the rulz-
r8c33-leds.sch file to rulz-r8c33.sch.  That file already has the changes you 
need.

Step 2.3 Double click on the “rulz-r8c33.sch” file (not the .pcb file) to open the schematic.

Step 2.4 The schematic editor opens extra dialogs by default.  Close them for now.

 Question
3. Symbols may be drawn to reflect the physical layout of the part, or the 

symbolic layout of the part.  Find the R8C chip's symbol.  Which layout 
was used for it?

4. Can you find where the new LEDs are to be added?

Step 2.5 Zoom in to the right part of the schematic by positioning (don't click) the cursor at one corner 
of the region you want, pressing the 'w' key, and then clicking on the opposite corner.

Step 2.6 To add components, click on the AND gate in the toolbar.  This brings up the component 
dialog.



Step 2.7 In the component dialog, type “resistor” into the filter.  Open the “Basic devices” category and 
select resistor-1.sym.  Click OK.

Step 2.8 On the schematic, each mouse click will now place a resistor.  Place four of them near pins 
P1.0 through P1.3.

Step 2.9 Repeat for led-1.sym (four of them) and gnd-1.sym (one).  The ESC key returns you to 
selection (normal) mode.

Step 2.10 The “Add Nets” icon (to the right of the Add Symbol icon) lets you add electrical connections to 
your schematic.  Click it to enter Nets Mode.

 To add a net, click on the starting point, click on any needed corners, and 
click on the end point.
To finish the current net and start a new one, right click anywhere.

Step 2.11 Connect each port P1.0 through P1.3 to one of the resistors.

Step 2.12 Connect each resistor to one of the LEDs (pin 1).

Step 2.13 Connect all the LEDs pins 2 to ground.  To connect a net to another net, just click on it.

Step 2.14 Exit Net mode to return to selection mode.  Drag a box around all your newly added parts to 
select them.



Step 2.15 Select the Autonumber option from the Attributes menu.

Step 2.16 The defaults are appropriate for us, so click OK to renumber the selected parts.

Step 2.17 Save your work often!

Step 2.18 Exit gschem.

Step 2.19 Run the gEDA Attribute Editor.  It's in the taskbar menu as Applications → Electronics → 
Circuit and PCB design → gEDA Attribute Editor.

Step 2.20 Use the File menu to load your schematic.

Step 2.21 Find the eight new components you added and enter 0603dj.fp in the footprint column for 
them.  Select those new entries and make them invisible with the Visibility menu.

Step 2.22 Save your work and exit the Attribute Editor.

The second objective is now complete!

Rotate your die to 2 to show your progress.



3 Updating Layouts
Overview:
Now that you have an updated schematic, the next step is to make the corresponding changes to the 
circuit board layout.  This part of the lab will teach you to use PCB, gEDA's layout editor.

Procedural Steps

Step 3.1 Double click on the “rulz-r8c33.pcb” icon in the hw folder to open up the PCB layout editor.

 The importer will add new elements in the middle of the board.  To avoid 
accidentally moving existing traces, it's a good idea to hide them before 
importing.  You cannot import new elements if any of the element layers (silk, 
pins/pads) are disabled.

Step 3.2 In the upper left, disable the component, solder, and far side layers by clicking on their 
buttons.

Step 3.3 Select File → Import Schematics to import the changes you've made.

 Question
5. Do you remember how your components were arranged in the 

schematic?

Step 3.4 Drag each new component from the pile in the middle of the PCB to a blank spot on the board 
so you can read its refdes, then move it to a suitable location for its final destination.  Keep in 
mind how they were arranged on the schematic, and arrange them the same way on the 
board.

Step 3.5 Re-enable the component layer so you can make sure you haven't placed an element on top 
of an existing trace.

 You can undo most edits with the “u” key.



Step 3.6 Once the elements are all in place, press the “o” key to optimize the rats nest.  The orange 
lines are unrouted connections.  The orange circles are potential connections to the ground 
plane on the other side of the board.

Step 3.7 Your board should look something like this:

Step 3.8 Switch to the LINE tool by clicking on the LINE button in the left-side tool box.

Step 3.9 Select Settings → Crosshair snaps to pins and pads

Step 3.10 Make the component layer the active layer by clicking the icon to the left of its button (in the 
photo above, the solder layer is the active layer).

 To add a trace, click on the starting point, click on any needed corners, 
then click on the end point.
To finish a trace and start a new one, press the ESC key once.



Step 3.11 Draw traces connecting the four R8C pins to the four resistors.

Step 3.12 Draw traces connecting the four resistors to the four LEDs.

Step 3.13 Draw one trace from the via just below the LEDs to the topmost LED.  This will connect all four 
LEDs.

Step 3.14 Select Settings → Only Names.  This locks all elements and traces, allowing only text to be 
moved.

Step 3.15 Select View → Grid size → No Grid, so that we may place the refdes's wherever we want.

Step 3.16 For each resistor and LED, drag the refdes's off the element to a clear place to the left of the 
resistors.  It's OK to place silkscreen ink over traces, but it's not OK to place it over pins or 
pads.

Step 3.17 Your layout should look like this (traces hidden for clarity):

Step 3.18 Switch to the TEXT tool.  Make the SILK layer active.

Step 3.19 Click to the right of the topmost LED.  A dialog box pops up in which you may enter text. Enter 
“P1.0  .1  .2  .3” with two spaces between each one, and click OK.

Step 3.20 Switch to the ROTATE tool.

Step 3.21 Click on the beginning of the placed text until P1.0 is on the top and .3 is on the bottom.

Step 3.22 With the cursor over the text, press shift-s twice to reduce the size of the text (just “s” makes 
it bigger).  Press SPACE to return to the selection tool to move the text so it lines up with the 
LEDs.

Step 3.23 Save your work with File → Save layout



 In a production environment, the following steps would likely be 
implemented in a Makefile to automate this process.

Step 3.24 Select File → Export layout... to bring up the export options.

Step 3.25 Select the gerber (RS-274X) exporter.

Step 3.26 The options are correct for us, so just click OK to export the design.

Step 3.27 Also run the PNG exporter.  Check the “photo mode” option and set the “dpi” to 600.  This will 
produce a photo-realistic rendering of our board.

Step 3.28 Exit PCB.

The third objective is now complete!

Rotate your die to 3 to show your progress.



4 Sending Out Design Files
Overview:
Now that you have an updated board, you must review the design, collect the design files, and email them 
to the people who'll make the board.

Procedural Steps

Step 4.1 In your “hw” folder you'll see there are many new files.  Double click on “rulz-r8c33.front.gbr” to 
open the gerber viewer (gerbv).

Step 4.2 You see just the top copper layer in the view window.  Use File → Open Layers to load the 
other *.gbr files, as well as the *.cnc file.

Step 4.3 Use the checkboxes to the left of the layer list to select which layers to view.  Select only the 
“front” layers to see what the board might look like.

Step 4.4 Drag the layers in the layer list to rearrange their order.  Sort them in the same order they'd be 
in the physical board, with paste on top and copper on the bottom.

Step 4.5 Right-click on the mask layers to invert their layer colors.

Step 4.6 Likewise, right-click on each layer to change their colors and transparency to reflect a real 
board...



Step 4.7 Exit gerbv.

Step 4.8 Double click on rulz-r8c33.png to view the rendering of our board.

Step 4.9 Close all windows and run the Email application again.

Step 4.10 Click the New button to compose a new email.

Step 4.11 Fill in “support” for the address, and “new board files” for the subject.  Write a suitable memo.

Step 4.12 Click “Add Attachment...” to add attachments.

Step 4.13 Select all the gerber (*.gbr, *.cnc) files and the PNG file and attach them.

Step 4.14 Click Send to send the Email out.

The fourth objective is now complete!

Rotate your die to 4 to show your progress.



5 Updating the Firmware
Overview:
New functionality isn't interesting unless the demo uses it.  In this part of the lab, we will update the demo 
firmware to show off our new circuitry.

Procedural Steps

 Eclipse is the standard GNU IDE.  While it can be configured to support a 
wide range of programming languages and environments, you are pretending to 
be an engineer who has already done all that, so your Eclipse environment is 
pre-configured for our lab.

Step 5.1 Open the Eclipse IDE via Applications → Programming → Eclipse

 Question
6. Do you remember which port you connected those LEDs to?

Step 5.2 The files “blinky.c” and “timer_a.c” have the new code you need already present, but protected 
by ifdefs:

#ifdef MORE_LEDS
  pd1 = 0x0f;
#endif

Step 5.3 Find each occurrence of that #ifdef and remove the #ifdef and #endif lines, leaving the code 
between them intact.

Step 5.4 Our new boards have arrived!



Step 5.5 Since these are factory-fresh boards, the USB chip must be configured.  Please plug in your 
gR8C lab board at this time, using the USB cable provided.  The power LED may come on 
dimly.

Step 5.6 On the right side of the screen, select the “Make Targets” tab, open the gR8C item, and 
double click on the “usb-config” target.  This will modify the EEPROM in the FT232R USB 
chip.

Step 5.7 Unplug the USB cable and plug it back in to reset the USB chip.

Step 5.8 Find the Run icon and click it to run our new firmware.

Step 5.9 If you've made the correct changes, the Console tab should show a successful build followed 
by the download process.  Once this is done, your board is reset and your code runs!

 Question
7. Did it work?
8. What does your demo do?

Step 5.10 Exit Eclipse.  Run the Email application again, and mail the “blinky.elf” file to support, just like 
the other files.  It's in the “sw” folder.

The fifth objective is now complete!

Rotate your die to 5 to show your progress.



6 Conclusion
Overview:
You've gotten a request from Marketing.  You've updated the design and written new firmware.  What's 
next?  Well, you could check your email again to see if there are any new requests... nah, you're done.

If you have time remaining, feel free to explore the other applications that Fedora Electronics Lab offers, 
or try your hand at other demo code for the gR8C board.  The design files for the gR8C Lab Board are all 
licensed as Free Software, so you may copy them if you wish, but they will also be available online.  You 
may also continue exploring the gR8C board after lab ends – each DevCon attendee got one in their 
welcome kit!

Rotate your die to 6 to show that you're done.

7 Online Resources

www.fsf.org

www.gnu.org

spins.fedoraproject.org/fel

www.gpleda.org

www.kicad-eda.org

www.redhat.com/services/custom

www.kpitgnutools.com

www.kernel.org

www.firefox.com

www.openoffice.org

www.renesasrulz.com/open-hardware

www.delorie.com/electronics/gR8C

www.delorie.com/electronics/rulz

http://www.delorie.com/electronics/rulz
http://www.delorie.com/electronics/gR8C
http://www.renesasrulz.com/open-hardware
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